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1. Courseware

1.1. Courseware files 

Overview 

In this exercise we will unpack the courseware files and set the default RobotStudio folder. 

Extracting the Courseware folder 

Along with the RobotStudio Courseware you have received a RobotStudio Courseware.zip 

file. 

l .  Right click the RobotStudio Courseware.zip file and select WinZip and Extract to.

2. In the Zip Self-Extractor dialog, browse to where you have your My Documents folder
and select the RobotStudio folder.

Browse For Folder 

Specify a location for e><lnld:ed files. 

-4 RobotStudio 

Code Snippets 

Geometry 

Instruction Templates 

JSSetupPrerequisites 

libraries 

ScreenMaker Projects 

� ScreenMaker Templates 

Solutions 

Stations 

Utilities 

lffil Extract 

Eldractto: 

:>cuments\RobotSbJd10 Training material\RobotSbJd10_6 O_Courseware 141219'1 • LJ 
Password 

C Show Password 

.._ __ o_K _ __,I LI __ c�an_ce_l �_,I LI __ He_lP _ __, 

I Make New Folder ) OK ) I cancel 

3. Click the Unzip/Extract button.

Setting the RobotStudio User Project Folder 

4. On the File tab click Options.
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d Options

5. In the Options dialog select Files & Folders.

6. In the User Project Folder click the browse[ ... ] button.

7. Browse to the Courseware folder that you just extracted and click the OK button.



Challenge 

I - .I 
Browse For Folder 

Specify a location for extracted files. 

,. RobotStudio ,., 

Backups 

l> Code Snippets 

,.! Courseware 
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I Geometry 

l> Libraries

l> RAPID Programs

l> Stations

l> Systems

Geometry

Instruction Templates

Libraries 

l .._� C , .. ___ ,. ... 1,-.. n ....... ;_.,...._

� I Ill I � 

I Make New Folder I I ()I( J I cancel I 

8. Click OK.

By setting the User Project Folder you have now created a shortcut that will appear in all 
open, import load and save dialogs. For example: 

�Open 

• Jahnberg, Anders • My Docum�ts • RobotStudio • Couruware • 

Organize• NEW folder 

• � RobotStudio 

Stations 

Coursevare 

"� Favorites 

a Desktop 
1 Downloads 

Recent Place. 

librari5 

, i] Documents 

:. Ji Music 

� Pictur6 
� Videos 

Filename: 

Name 

Gmm�ry 

libraries 

RAPID Programs 

Stations 

Systems 

0 Load Goom<t,y 

Here we can see the Courseware button in the Open dialog 

Select a fife to preview. 

... I Station files r.,sstn) ... i 
Qpen I I C.ncol I 

If you have an internet connection you can visit the RobotStudio community. Go to 

http://www.abb.com/roboticssoftware. 
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2. Learning the basics

2.1. RobotStudio Overview 

2.1.1. Exploring RobotStudio 

Overview 

Before starting with the actual exercises, we will take a quick look at RobotStudio and 
commonly used functions. 

To open a demo station 

Now we will open a demo station to play with. Do not save any changes to the station during 
this exercise. 

I. On the Start menu select
All Programs > ABB industrial IT> Robotics IT> RobotStudio 6. Ox > RobotStudio

to start RobotStudio.
2. 1n the File tab, click Open.

- Ope-n

3. Browse to the folder \Courseware\Stations and o

-O• ► Ubr�nes ► Documents ► RobotStudio ► Courw-v.aue ► Stilt,ons ► 

fi� Edit VW!W Tools Help 

Organue • � Op@n wiltl RobotSw310 6.01 .. Share w,th • E-�d Bum 114N' IOlder 

Favomts 

• De-sl:lop 

Oownoads 

,.,_, REcentPlaces 

SUPPORT 

Muoc 

- PJctures 

I- Videos 

Computer 

_, SE (\\nmea) {B:) 

local Disk(C:) 

Docum ... A·m-qe ttt f-olde • 
Stat1ors 

Sol11t101K 

De bur Sation IR!M600_0ffhnt..rspa9 

� Delxn'Si.uonlRS4600_0nh� 

• Expl0fino.n.s1n 

�- : :;:;.:::: .. 

Gl�Stauon.npag 

GlueSt.1t1on_An.Jtyzc.npag 

-.,;J IRB460_palletizing.npag 

� Jobs_RS6JSJMO 

Reachobiliry.,nan.npag 

.. SC_Pallctizing_Robot.np&g 

.r WII\A?P (\\SE·S-OXK>639.subb.com) (K.1 

0�1e mod f,ed. 201S·06-2514.07 
Sae: 9.00MB 

- •-, J

Dote 2015-06-25 H:07 

Siz� 9MB 

Author: 

ntte: 

Ch.inge Log: 

The main parts of RobotStudio window 

The picture on the next page shows the main parts of RobotStudio: 
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Quick Access Toolbar 

For quick access to commonly used commands and settings. To add an item to the 
toolbar, right click the item and select Add to quick access toolbar or click the 
arrow next to the tool bar and select Customize Commands. 

2 Tabs 

The tabs contain collections of commands and setting items for different 
functions according to the following table: 

File Opening, saving stations and options etc. 

Home Building up stations, creating systems, creating paths with 
graphical programming. 

Modeling Creating and grouping components, creating solids, curves and 
surfaces, measurements and CAD operations. This is also from 
where you create Tools, Conveyors, Smart Components and the 
Mechanism Modeler. 

Simulation Setting up, configuring, controlling, monitoring and recording 
simulations. 

Controller For working with system parameters and configuration and setting 
up relationships to transfer programs, data etc. between controllers. 
(VC (Virtual Controller) or live controllers) 

Rapid Editor for writing new and/or debugging existing Rapid programs. 

Add-Ins PowerPacs and Add-Ins. 

Modify This is a contextual tab, which is only visible when an object is 
selected. It lists specific commands for that object type. 
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Learning the Basics 

Creating a New Station Using a Solution Folder 

1. In the File tab, click New and then select a new Solution with Station and Robot
Controller

Info 

Recent 

Print 

Share 

Online 

Help 

(J · ; Explonng • ABB RobotStud10 6.03 (64.-brt) 

Stations Solution with Slat1on end Robot Conlroler 

Files 

SolubonwilhEmptyStabon Sok.ooliNmne 
C,eales • S:Xutllon file 5tn.Y.:b.>1e o:. 111, 'lfl'l9 ari emphl myScaa;n -·� 

Solullon wit, Smoon and R0bo1 Con11'oller 
eat.\& ill !IOI IIPl !If' d .e, I t ! 

",t- t-1•111?1 t- e 

RAPID Module File 
C1e11te, 11 RAPlO modul� file and ope!'ll! 11 in 11,e 
ed1tt:r 

Controller Configur.•on File 
C,eate.s II smndalore c:::iMi�rat _ ik- arid c;:prris ,t 
mthf"edrtor 

locolion. 

...... 

IRB1600_!ikg_1..2m 

jRdxitw-&.az.01.00 

IIFIBl6006kg1..2m ·I

Power and productJvity 
for a better world' 

n.Hlt
,., .. , ...

2. Name it mySolution. Browse to the location Courseware\Solutions and create a folder 
named Module_ I and select or go in to that folder and press Select Folder.

3. Name the system IRB1600_6kg_l.2m. (Note that the location is predetermined by the 
Solution.)

4. Make sure that the RobotWare is version 6.0x and in the robot model drop down 
window, find the robot IRB 120.

5. Press Create.

6. ln the File tab select Save Station As.

7. Browse to the folder \Courseware\Solutions\Module_J\mySolution\Stations.

8. Save it as mySolution_l. 

The solution folder is used to help you, as a user, keeping a well-structured folder system 
that is easy to navigate through. Later in th.is module you will also see the other features that 

solutions have. 

Learn more 

Click the Help button _ in the top right comer ofRobotStudio. 

See the help section for information about 

Workflow for building a new station Creating stations and systems. 

2.2.2. Adding a Tool 

Overview 
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We will now import and attach a tool to the robot. This is done in two steps: first we import the 
tool to the station and then we attach it to the robot. 



Learning the Basics 

The tool that we will import is a library component, which means that it is a RobotStudio object 
that has been saved as a separate file. The library import creates a link from the station to the 

library file on the hard drive. Therefore, several stations can share the same library component. 

On the Home tab you can find the Import library button, it has two sections: 

1. The upper button opens up a dialog where you can browse for libraries.

2. The lower part that opens up default RobotStudio libraries and personal galleries.
Import 

Library 

Importing the Tool 

1. Open the station from the last exercise (mySolution _I), unless it is already open.

2. In the Home tab click the Import Library button. Since you have already created the
Courseware gallery to this menu, you can now easily select the needed library
component from this gallery. Click the Courseware gallery and select Pen.

Home r 1odehng SImuratIon 

Robot 
System• 

-

Import 
Geometry• 

� 

Controller RAPID 

t: 0 
0 

0·<:r 
Frame -arget Path 

I-----, 

,;dd-lns 

It:] •each Target �'-'l ·ask 

... e,a�. tr- '"'on WorkobJed 
Other MultiMove 

li) Vie.·, Robot at ,arget ool 

Path Programming r.l 

•. 6_161 

WObJO 

toolO 

Setting UserLibraiy 

Equ1pmert 

Solution Libraiy 

CourseWare 

� ,___._x
_, 

myStation_l:V'iewl x �---------------

Documents 

Locations_ 

Brov,SE for Library_ Ctrl-J 

� 

� Courwwa� 

box 

Jigg 

mySpinteCool 

SC_lnfeeder 

G\'-r'_Sl 

Fence 
I I 

myConveyor 

.Pen 

SC_OutPaflet 

docklng_stabon 
• 

fence 

my_Shde 

SC 
FenceCreatorYeflcM 

SC_ VacuumGnpper 

Single Dose-

The tool will be imported to the station and placed at the origin of the world coordinate 
system, thus hidden inside the robot. However, in the Layout browser you can see that 
the tool has been imported. 

Attaching the Tool 

1. Inside the La out browser, drag the tool Pen and drop it on the robot /RB I 600.
Layout Paths&Targets Tags ; x 

ii, myStabon_ 1• 

Mechanisms 

t � IRB120_3_58_01
· • Pen 
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2. Answer the question ''Do you want to update the position of Pen" with Yes.

Update position 

Do you want to update the position of 'Pen"? 

Yes l I No J I Cancel 

The tool is moved and attached to the wrist of the robot. 

3. Save the station as mySolution_2.

Notice that RobotStudio adds the _2 automatically.

2.2.3. Importing the Controller Cabinet 

Overview 

We will now import a model of the controller cabinets to the station. The controller model is 
for visual representation only, the Virtual Controller runs regardJess if there is a cabinet or 
not. 

Importing the Controller Cabinet 

I. Open the station from the last exercise (mySolution_2), w1less it is already open.

2. On the Home tab click the Import Library button (lower section).

3. ln the Equipment folder, select the IRC5 _ Control-Module I ibrary.

The cabinet will be imported to the station and placed at the origin of the world 
coordinate system. 

4. Save the station as mySolution_3.

2.2.4. Moving the controller cabinet 

Overview 
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We will now move the controller to a more suitable position in the station. lf not the exact 

position is important, Freehand move is an easy way to modify the position of objects. 
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RobotStudio has several functions for moving objects, each suitable for different situations. Jn 
this exercise the exact position is not important as long as it is placed out ofreach from the 
robot so we will use the Freehand move. 

Moving the controller cabinet part 

1. Open the station from the last exercise (mySolution_3), unless it is already open.
2. ln the Layout browser select IRC5 _ Control-Module or use selection level Part to make

the selection directly in the graphics window.

3. On the Home tab, in the Freehand group click the Move +it· button.

4. Click and hold on the green arrow in the Freehand move cross, then drag the controller
one floor square (about 1 meter) to the right of the robot (negative Y direction). Then
click and hold on the red arrow and drag it one square backwards (negative X direction).

'-

5. Save the station as mySolution_ 4.

2.2.5. Importing CAD files 

Overview 

You can add work pieces and custom equipment, like fixtures or conveyors, by importing the 
CAD models of the objects. In this exercise we will import a table and box. 

Importing the CAD files 

1. Open the station from the last exercise (mySolution_ 4), unless it is already open.
2. On the Home tab click Import Geometry.
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2.3.8. Saving the robot program 

Saving the robot program 

Summary 

1. 

Synchroni=e to B.APID­

Synchroni=e to Siation.. 

.Load Program­

ia,e Program As .• 

Rename Program_ 

D�Jete Program 

Lei•, Module­

Load !:,!odule-

Go -o E,rogram Pointer 

Go-o M.Q.tionPointer 

.,,, folio,•, Program Pointer 

� AdJust Robtargets. 

2. In the folder \Courseware\RAPID Programs save the program as BoxProgram_l.

Now we have created a robot program that can be loaded to a real robot. The saved modules 

can be viewed or edited using the Rapid editor or any text editor. 

Basically, ow· program exists in three independent versions now: 
• In RobotStudio, where the positions and motion properties are saved in the path.
• In the virtual controller, where it is stored in the controller's program memory just as on

a real controller.
• As files on the hard drive, which we saved from the virtual controller through

RobotStudio.
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